“SonarQube requires Java 11+ to run” Hatası Çözümü

Yazılım Mühendisliği

Bilgisayarımıza SonarQube kurulumu sonrası ilk çalıştırmada “SonarQube requires Java 11+ to run” hatası alabilirsiniz. Bunun çözümü oldukça kolay.

SonarQube Java 11 ve üstü Java sürümü istemektedir. Java 11 ve üstü sürüm kurulu ancak yine çalışmayabilir.

SonarQube bilgisayardaki Java 11 ve üstü sürümün yerini bilemediği için çalışmıyor. SonarQube’ye Java yerini konfigürasyon dosyasında yazarak belirtmeliyiz.

SonarQube’nin kurulu olduğu dosya içerisindeki \conf\wrapper.conf dosyasındaki ilgili satıra Java sürümünün yolunu yazınız. Örnek vermek gerekirse;

wrapper.java.command=C:\Program Files\Java\jdk-11.0.6\bin\java

Sorun çözülecektir.

İyi kodlamalar.

Leave a Reply

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Burak KUTBAY 2010 - 2020
%d blogcu bunu beğendi: