Arşivler

PostgreSQL FATAL: no pg_hba.conf entry for host user , database , SSL off Hatası Çözümü

blank

PostgreSQL veritabanına uygulamanızdan bağlanmayı denerken aşağıdaki hatayı alabilirsiniz;

Postgre[28000] FATAL: no pg_hba.conf entry for host user “postgres”, database “postgres”, SSL off

Bu hatanın nedeni veritabanına erişim yetkisi olmamasından kaynaklanmaktadır. Bunun için yapmamız gereken;

PostgreSQL’inizin kurulu olduğu dizine gidin pg_hba.conf dosyasını açınız. Bu dosyanın içerisinde hangi kullanıcının hangi veritabanına hangi ip’den girebileceğini belirleyebiliriz. Yapı şu şekilde;

# TYPE DATABASE USER CIDR-ADDRESS  METHOD
host  all  all 0.0.0.0/0 md5Code language: PHP (php)

Yukarıdaki satırda her kullanıcıya her veritabanından hernagi bir ip’den girebilir.

# TYPE DATABASE USER CIDR-ADDRESS  METHOD
host  postgres burak  0.0.0.0/0 md5Code language: PHP (php)

Yukarıdaki yazımda ise “postgres” veritabanına “burak” kullanıcısı her ip’den bağlanma izini veriyoruz.

PostgreSQL’in ilgili dosyasına gerekli ayarlamaları yaptıktan sonra bu hata ortadan kalkacaktır.

İlgili veritabanı içerikleri

Spring Data MongoDB, MongoDB Docker Compose, Debezium ve Kafka ve Spring Boot dersleri.

İlgili veritabanı ve Spring içerikleri

Veri erişimi konusunu derinleştirmek için Spring Boot Dersleri, Testcontainers ile MongoDB testleri ve Spring Data MongoDB içeriklerine bakabilirsiniz.